Skip to main content

Fallout: London devs confirm the massive mod will need to downgrade your copy of Fallout 4, as the game's next-gen update "isn't stable enough"

"It's been an utter frustration and every setback requires the testing process to restart."

The traffic warden from Threads recreated in Fallout: London.
Image credit: Team FOLON

Fallout: London's project lead has confirmed that the massive mod will need to downgrade your copy of Fallout 4 to a version from before the next-gen updates that dropped earlier this year in order for you to be able to play it. The reason cited is that the next-gen version of Bethesda's RPG "isn't stable enough".

If you're out of the loop, Fallout: London's a full conversion mod for Fallout 4 that's set to let us explore a post-apocalytic version of the English capital, complete with fresh factions and quests. After Fallout 4's next-gen update forced its creators to abandon their planned release date of April 23, the mod has been left in what's felt like a bit of a purgatory.

However, at the weekend, the team behind Fallout: London released a statement revealing that the mod is now undergoing QA testing by GOG.com, the storefront that'll be disrtibuting it, and is therefore just "waiting for the final green light". One detail mentioned in this statement is that the mod not only has its own installer, but also a downgrader, and project lead Dean 'Prilladog' Carter has now revealed that the latter certainly isn't just being chucked in there as a cool optional inclusion, as you might have assumed.

"GOG have been amazing through all of this. To be honest, we've been the ones causing them the issue," Carter has since explained in a post on the game's Discord server (thanks, Ars Technica). "What with us having things break due to the next-gen [update] and then needing the 3rd parties to update," he continued, "Then waiting for them to be fixed, only for the fact that at the 11th hour we've discovered that the next-gen [version of Fallout 4], even after updates, isn't stable enough and thus we are now going out on the old version - [hence] the need for a downgrader."

While this is an idea that Carter and the Fallout: London team have mentioned at various points this year, with it being something a lot of fans who didn't plan on updating their copy of the game to the next-gen version in order to avoid any issues getting their existing mods to work without having to wait for updates had been advocating for. However, the London modders had been hesitant as recently as May to actually commit to, as it'd essentially double their workload assuming they still planned to release on next-gen too.

Sadly, it seems this is the exact reality they've had to face. "The most annoying thing for us is having something. Then delaying to wait for the next-gen 3rd party fixes. Then having another update. Then having it still not working," Carter outlined in another post. "It's been an utter frustration and every setback requires the testing process to restart. Which is why we've decided to go with the downgrader route and when the next-gen is sorted, update it for that. Which is an internal frustration, as we now have to manage multiple things, which adds further stress."

If you're after something interesting to do Fallout 4 mod-wise while you patiently wait for Fallout: London to finally drop once all the necessary testing is done, check this out.

Read this next

news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news
news